Search Results

Search results 1-20 of 36.

  • RE: Script Probleme

    sauger999 - - eigene Erweiterungen

    Post

    Guck mal hier, habe auch einige Fehler mit den GPIOs gemacht. http://rpi-controlcenter.de/showthread.php?tid=543 vielleicht liegt hier dein Problem!

  • RE: Script Probleme

    sauger999 - - eigene Erweiterungen

    Post

    Hallo, habe im "home" einen Ordner "scripte". Mein "An Kommando" lautet: /home/scripte/GTz.sh Rechte habe ich auf 755 hier wurde schon einmal darüber geschrieben: http://rpi-controlcenter.de/showthread.php?tid=543&pid=3614#pid3614 und jetzt noch ein Tip den ich von rmjspa bekommen habe! Leg doch mal Deine Scripte im Ordner usr/bin ab. Dann kannst Du dir den Pfad im SHC auch sparen und es ist wieder eine Fehlerquelle ausgeschlossen. Also unter Script imSHC nur noch einsetzen GTz.sh ohne Pfadangab…

  • RE: Bewegungsmelder (pir)

    sauger999 - - Aktoren

    Post

    Hmm, hab eben gesehen dass ich irgend ein anderes Problem habe, hab es heute aber nicht so richtig geschafft! Elemente von anderen Slaves stehen beim Countdown zur Verfügung! Der Pir ist als Eingang angemeldet auf dem Slave erscheint aber nicht beim Countdown. Alle Schaltserver laufen! Ich weiß, es ist wieder ne gaaanz kleine Sache! :@ Grüße Was ich heute zum dritten mal feststellte, weiß aber nicht ob es irgendein Zusammenhang zu meinen Aktivitäten mit PIR und Countdown hat. Seit drei Tagen bes…

  • RE: Bewegungsmelder (pir)

    sauger999 - - Aktoren

    Post

    Hmm, das ist ja immer seltsam! Angemeldet ist das Element auf dem Master mit schaltserver des Slaves. Beim hinzufügen der Elemente beim Coundown siehst du nur Elemente des Masters. Die Schaltserver sind aber alle aktiv! Ich weiß es wieder, irgendwas gaaanz einfaches! :@ Grüße

  • RE: Bewegungsmelder (pir)

    sauger999 - - Aktoren

    Post

    Quote from rmjspa: “ Zu erst erstellst Du ein Schaltbares Element mit dem Eingang des PIR. Dann ein Ereignis positive Flanke auf das oben erstellte Element Mit diesem Ereignis Triests Du einen Countdown. Mit dem Countdown schaltest Du das Relais. Dann hast Du das gewünschte Ergebnis. ” Hallo rmjspa, so wie du beschrieben hast hab ich es versucht. Erst ein Element angelegt dann Bedingungen und Ereignis angelegt und wie beschrieben funktioniert es auch, halt eben der Zeitpuffer fehlt mir. Beim Anl…

  • RE: Bewegungsmelder (pir)

    sauger999 - - Aktoren

    Post

    Quote from premo: “ Ja, als GPio Eingang anmelden. Anleitung ist für 2.0.3!! Source Code (23 lines) ” Hallo Ich benötige mal wieder Eure Hilfe, wiedermal MasterSlave. Ich habe am Slave einen Bewegungsmelder mit dem ich für eine bestimmte Zeit ein Relais auslösen möchte. Nun habe ich versucht dies über Countdown zu realisieren, aber die Funktion ist nicht möglich, ich kann nur die Sachen auswählen die direkt am Master hängen. Dann habe ich eine Bedingung und ein Ereignis nit Positiver Flanke erst…

  • RE: Bewegungsmelder (pir)

    sauger999 - - Aktoren

    Post

    Quote from premo: “ Quote from Bkm: “ Quote from premo: “ Source Code (2 lines) ” "Bewegungsmelder" mit "an" taucht bei mir , vorgegangen nach der Anleitung und auch alles so benannt, gar nicht auf ” Die Anleitung ist für 2.0.3 (habe ich oben im Beitrag jetzt vermerkt) In 2.2.2 muss du am Ende der Anleitung noch ein "Ereignis" anlegen. ” Hallo Ich benötige mal wieder Eure Hilfe, wiedermal MasterSlave. Ich habe am Slave einen Bewegungsmelder mit dem ich für eine bestimmte Zeit ein Relais auslösen…

  •  :D  :D  :D gMaN, DANKE das war es! Aber auch dank an alle Mithelfer! ES FUNKTIONIERT! Es liegt daran, wie gMaN schon geschrieben hat, der "www-data" User muss Passwortfrei sein, dann geht das Skript auch durch! Als "an Kommando" im SHC habe ich nun "ssh 192.xxx.xxx.125 GTz.sh" Dank euch!

  • Quote from gMaN: “ versuch mal mit "sudo su www-data" die script auszuführen ( im terminal Manuel ) und kopiere mal die RSA Dateien nach /var/www/.ssh danach die rechte anpassen chown -R www-data:www-data /var/www/.ssh chmod 0700 /var/www/.ssh chmod 0600 /var/www/.ssh/id_rsa denke das es so laufen müsste ” Bis jetzt habe ich es nicht geschafft "www-data" passwortfrei zu bekommen, der User ist doch dann der "www-data"? Einen neuen RSA Key konnte ich mangels Rechten noch nicht erstellen und das Ei…

  • Quote from rmjspa: “ Ja, dann sind mir im Augenblick die Ideen ausgegangen. ” Dank dir trotzdem! Habe das ganze nochmal im Benutzer root probiert, gleiches Ergebnis, im Terminal ok und bei SHC null.

  • Das ist ja irre, geht auch nicht! Habe scripte verschoben in usr/bin, im SHC als Kommando ssh.sh und habe script ssh abgeändert auf "ssh pi@192.168.178.125 GTz.sh" (was per Terminal wiedermal problemlos funktioniert) darauf geachtet dass Rechte755. und will wieder nicht!

  • Hallo, erstmal Dank für Eure Interesse! Ich schreibe nochmal alles von ganz vorn und hoffe dass ich nichts vergesse! Ich habe zwei Raspberry's die ich dazu bringen möchte "im SHC" ein Skript auf den slave auszuführen. Raspi A=Master mit IP xxx.100; Raspi B=Slave mit IP xxx.125. Was ich bis jetzt gemacht habe: Beide Raspberrys habe ich einen Passwortfreien SSH Zugang installiert, der auch super im Terminal funktioniert. Für Interessenten ist dieses diese Anleitung wirklich SUPER! https://www.yout…

  • Quote from gMaN: “ apache läuft glaube ich unter www-data denke du must den rsa schlüssel unter www-data user installieren dann sollte es klappen ” Hallo gMaN kannst du mir mehr dazu sagen, finde irgendwie kein Anfang! Komme mit "pi" und "root" passwortfrei auf den slave aber mit dem "www-data user" komme ich nicht weiter!

  • Hallo gMaN kannst du mir mehr dazu sagen, finde irgendwie kein Anfang!

  • Quote from gMaN: “ apache läuft glaube ich unter www-data denke du must den rsa schlüssel unter www-data user installieren dann sollte es klappen ” Hallo gMaN kannst du mir mehr dazu sagen, finde irgendwie kein Anfang! Komme mit "pi" und "root" passwortfrei auf den slave aber mit dem "www-data user" komme ich nicht weiter!  :huh:

  • Quote from gMaN: “ apache läuft glaube ich unter www-data denke du must den rsa schlüssel unter www-data user installieren dann sollte es klappen ” Jetzt hast du mich aber als Junior Member erwischt! Kannst du mir mehr dazu sagen, gucke gerade ins Blaue! Gruß

  • das sudo vornweg will er auch nicht! [hr] Quote from gMaN: “ versuch mal in shc ein "sudo" vor den befehl zu hängen oder versuch in putty mit dem user unter dem apache läuft das script auszuführen evtl darf dieser nicht auf die ssh-auth dateien zugreifen hier müssen evtl nur die rechte angepasst werden ” Also mit meinem StandardUser "Pi" geht das signal ohne Passwort ans Relais. Nun habe ich mit User "Root" dann kommt die Passwortabfrage. Läuft Apache unter Root?? Ich versuch mal den RSA Schlüss…

  • Quote from gMaN: “ kann dir empfehlen schau dir mal folgendes an: http://linuxproblem.org/art_9.html dannach kannst du einfach ein befehl direkt ausführen z.b. ssh pi@slave ./script.sh ” Hmm, das ist das was ich schon gemacht habe, wie gMaN es schon vorgeschlagen hat, ich brauch beim einloggen auf dem Slave kein Passwort angeben, mit Putty geht der Befehl ohne Passwort dur und schaltet das Relais! :s Werde es wohl doch über Countdown machen müssen!

  • Ich verstehe es nicht! ich habe noch weiter getestet und komme zu keinem Ergebnis! Ich habe zwei Raspis mit verschiedenen IPs- Ich habe auf beiden das gleiche Script und an jedem Raspi auf den gleichen GPIO ein Relais! Auf dem Master habe ich zwei schaltbare Elemente angelegt, eins auf das Script zum schalten des Relais am Master und eines zum Relais am Slave. Löse ich das Script am Master aus, schaltet das Relais. Löse ich das Script auf den Slave "an Kommando-ssh pi@192.168.178.125 sudo /home/…

  • Quote from tommy_0307: “ Quote from sauger999: “ nein, ich habe ihn soweit dass er den Befehl ausführt! Ich logge mich per Putty auf 192.168.178.100 ein und sende "ssh pi@192.168.178.125 sudo /home/scripte/GTz.sh" zum xx.125 und das Relais schaltet. nur direkt im SHC tut es das nicht! ” Kann ich bestädigen. Habe das Problem auf dem Master. Seit update auf 2.2.5 wird kein neu angelegter Befehl Script mehr ausgeführt. Die alten funktionieren nach wie vor. Komme auch auf keinen grünen Zweig! :huh: …