SHC 2.2.7 - Scripte werden nicht ausgeführt - Magnetkontakt wird nicht abgefragt

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • SHC 2.2.7 - Scripte werden nicht ausgeführt - Magnetkontakt wird nicht abgefragt

      Hallo,


      ich habe am Pi einen 433mhz Sender welcher Top funktioniert.

      Problem 1:

      Nun wollte ich noch einen Magnetkontakt nutzen, allerdings wird der Status nicht ausgewertet.
      Ich habe diesen als Eingang definiert und auch den GPIO zugewiesen. Der Button bleibt aber rot.

      Getestet wurde es auf einen Pi B & Pi 2.


      Problem 2:

      Ich kann keine Scripte ausführen, weder py noch sh.
      Bei sh steht natürlich !#/bin/sh am Anfang.

      Weder ./ noch mit dem kompletten Pfad kann ich sie starten inkl. sh /Datei.sh
      Im Terminal läuft alles wunderbar und auch Rechte sind gesetzt.

      Ach bringt es nichts, wenn ich das Script direkt eintrage, nicht mal ein mkdir klappt :(


      Problem 3:

      Da ich eventuell dachte, dass ich einen Fehler gemacht habe, habe ich mir das fertige Image geladen.
      Aber hier ist kein SSH aktiviert.
      Muss ich den Pi erst mit dem TV verbinden und dann SSH aktivieren?
    • Moin

      Zu Problem 1:
      Ist bei einrichten des Schaltservers auch
      Gpio lesen und schreiben aktiviert worden.
      Wenn ja, wie wurde der Magnetkontakt angeschlossen.

      Zu Problem 3:
      Wenn das fertige Image genommen wird dann gibt es keine Desktopoberfläche.
      Weil es auf Jessie light installiert wurde.

      Wenn du mit Putty zugriff hättest, dann kann man mit "sudo /etc/init.d/ssh start" SSH starten.
      Kann besser Hardware als Software !

      The post was edited 1 time, last by premo ().

    • Moin,

      Danke für deine Antwort.


      1. Ja GPIO lesen/schreiben sind aktiviert.
      Magnetkontakt wurde mit 3,3v, Ground und GPIO 15 angeschlossen.
      Und im SHC als Eingang definiert, hab dort auch 0 und 1 probiert.

      Ich habe dann auch den GPIO auch geändert, da es ja Pin und WiringPi Nummern gibt.

      Klappt leider nicht.

      Der Sensor selbst funktioniert aber, wenn ich mein python Script ausführe.
      Dort erkennt er immer 0 oder 1.


      3. Ach okay, dann brauch ich ja gar keinen Bildschirm anschließen.
      Wie ich ssh starten kann ist mir bekannt, aber wie kann ich mich denn mit putty verbinden, wenn ssh deaktiviert ist ?
      Hab lange kein Windows geschweige denn putty benutzt.
      Oder kann ich schon die Karte in den Rechner hauen und eine Option ändern?
    • Ah alles klar, dann werde ich nachher nochmal schauen ob SHC den irgendwie erkennt.

      Ja habe auch den 10k Widerstand genau da. high_low.
      Zwischen Gnd habe ich noch zwei 470er Widerstände in Reihe.
      Kann es daran liegen? Sollte ja aber eigentlich nicht, da es wie gesagt in python gut funktioniert.



      Meine die microSD Karte.
      Wenn ich die mounte, kann ich dann den ssh start Befehl nicht in den autostart packen?
    • premo wrote:

      PsychoHH wrote:

      Zwischen Gnd habe ich noch zwei 470er Widerstände in Reihe.
      Die nehme mal weg, mit dem mounten der SD Karte kenne ich mich nicht aus.
      Leider alles verlötet :/


      Danke euch für die Antworten.


      SSH konnte ich aktivieren.
      Pi an TV geschlossen und Tastatur ran, dann ging es per Terminal ziemlich easy.

      Magnetschalter funktioniert auch, ist zwar ein wenig träge die Anzeige im SHC aber es klappt erstmal.
      Woran das aber lag, keine Ahnung, PIOs waren vorher auch richtig und auch die richtige Nummer eingetragen.


      Was aber definitiv nicht zuverlässig klappt ist das starten einen Scriptes.
      Es wird einmal abbearbeitet und dann mal wieder nicht. vielleicht bei 2/10 Durchgängen.
      Aber dann auch gar nicht mehr.

      Es war jede Stunke/Minute usw. ausgewählt, sodass das Script dann immer ausgeführt werden könnten ohne cooldown.

      Werde aber einfach ein python Script nutzen, welches den Zustand ständig prüft, bzw. jede Sekunde.
      Und dann halt bei Bedarf das Shell Script ausführen. Das ganze klappt ziemlich zuverlässig.
    • PsychoHH wrote:

      Magnetschalter funktioniert auch, ist zwar ein wenig träge die Anzeige im SHC
      Die Trägheit kann man verbessern, indem man in der Konfiguration "fast" auswählt. Das lag ist dann etwa 2 sek. Also wenn der Magnetkontakt eine Tür überwachen soll, kann man die Kontrollfunktion aushebeln, wenn man ganz schnell durchgeht.

      Ansonsten wird, wenn man dies berücksichtig jeder trigger zuverlässig erkannt und damit kann man dann einen z. B. einen Countdown für die Sirene starten und ein Script zur Versendung einer Pushnachricht. Auch das funktioniert zuverlässig.
      SHC Master B2+ WLAN sowie 1 Slave B2+, 2 Slave B+ und 2 Slave Raspi B. 5x Pi Cam; Imac mit OSX El Capitan; Iphone 6 plus; Ipad mini; Lenovo Android Tablet.