Nach mehreren Neustarts Fehler in der Weboberfläche

    • Nach mehreren Neustarts Fehler in der Weboberfläche

      Hi,
      eigentlich funktioniert bei mir alles wie es soll. Ich bin aber noch am experimentieren. Nach mehreren Neustarts und umkonfigurationen bekomme ich diesen Fehler.
      Da ich mir nicht helfen kann, hilft nur noch neu flashen ;(  Vielleicht hat ja von Euch jemand einen Rat

      Source Code

      1. XML Error
      2. Die XML Datei konnte nicht geladen werden
      3. Klasse: RWF\XML\Exception\XmlException
      4. File: lib/xml/xmleditor.class.php
      5. Line: 63
      6. Code: 1100
      7. Stack:
      8. #0 lib/xml/xmleditor.class.php @ Line: 88
      9.    RWF\XML\XmlEditor::createFromString('...')
      10. #1 lib/xml/xmlfilemanager.class.php @ Line: 115
      11.    RWF\XML\XmlEditor::createFromFile('/var/www/shc/shc/data/storage/switchables.xml')
      12. #2 /var/www/shc/shc/lib/switchable/switchableeditor.class.php @ Line: 152
      13.    RWF\XML\XmlFileManager->getXmlObject('switchables...')
      14. #3 /var/www/shc/shc/lib/switchable/switchableeditor.class.php @ Line: 144
      15.    SHC\Switchable\SwitchableEditor->loadData()
      16. #4 /var/www/shc/shc/lib/switchable/switchableeditor.class.php @ Line: 1483
      17.    SHC\Switchable\SwitchableEditor->__construct()
      18. #5 /var/www/shc/shc/lib/view/room/viewhelpereditor.class.php @ Line: 168
      19.    SHC\Switchable\SwitchableEditor::getInstance()
      20. #6 /var/www/shc/shc/data/commands/web/room/showroomajax.class.php @ Line: 42
      21.    SHC\View\Room\ViewHelperEditor->getViewHelperForRoom(1)
      22. #7 lib/request/commands/ajaxcommand.class.php @ Line: 32
      23.    SHC\Command\Web\ShowRoomAjax->processData()
      24. #8 lib/request/abstractcommand.class.php @ Line: 77
      25.    RWF\Request\Commands\AjaxCommand->executeCommand()
      26. #9 lib/request/requesthandler.class.php @ Line: 184
      27.    RWF\Request\AbstractCommand->execute(RWF\Request\HttpRequest, RWF\Request\HttpResponse)
      28. #10 lib/request/requesthandler.class.php @ Line: 133
      29.    RWF\Request\RequestHandler->handleWebRequest('ajax...', 'showroom...')
      30. #11 lib/request/requesthandler.class.php @ Line: 99
      31.    RWF\Request\RequestHandler->__construct('ajax...', 'showroom...')
      32. #12 /var/www/shc/index.php @ Line: 25
      33.    RWF\Request\RequestHandler::handleRequest()
      34. #13 {main}
      Display All
    • Nach mehreren Neustarts Fehler in der Weboberfläche

      Die Datei liegt auch im Backup. Einfach daraus wieder herstellen, die Rechte neu setzen und dann sollte alles wieder in Ordnung sein.


      Sent from my iPhone using Tapatalk
      Gruß

      Matthias
      1x RasPi b, 3x RasPi b+, 1x RasPi 2, 2x RasPi 3, 2x RasPi Zero, 1x RadPi 4 (4GB) 1x BananaPi M1, 1x BananaPi R1, 1x BananaPi M3, 2x OrangePi Zero, 1x OrangePi One

      BTC: 1AJgWX9SXzH6wpoQ9d5HpkLcct6kAuatvJ
      NMC: N9fF4858aVWpY3Zu5xSxBV4XLvZ73D8eKV
    • RE: Nach mehreren Neustarts Fehler in der Weboberfläche

      Hatte ich auch schon so versucht. Allerdings die Rechte nicht vergeben. Ich versuchs das nächste mal.
      Trotzdem wüsste ich gerne wo das herkommt?

      Nochwas.. bevor ich wieder einen neuen Threat auf mache.
      Ich habe meinen Pi schon mal versucht so zu verbauen, so wie er später auch verbaut werden soll. Dabei musste ich alle Kabel abziehen. Jetzt habe ich vergessen, welche GPIO für den DHT22 zuständig war ;(. Die sp-1.xml habe ich mir schon angeschaut. Aber wo steht da der GPIO?