Schaltserver stürzt ab

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • RE: Schaltserver stürzt ab

    xerox wrote:


    agent47 wrote:


    @xerox
    Das ist schonmal ein Ansatz. Ist an der Problematischen Steckdose irgendetwas anders (Protokoll o.ä.)?


    Hi,

    der einzige Unterschied ist das Icon, aber das kann wohl ausgeschlossen werden.

    Seit dem oben erklärten Workaround läuft bei mir alles sauber durch, 1 Master 2 Slave, alle auf 2.2.2 geupdatet schalten regelmäßig Ereignisse und Schaltpunkte.


    JD2K7 wrote:


    agent47 wrote:


    verwendet ihr rcswitch-pi oder Pilight?


    Ich verwende rcswitch-pi...


    [hr]
    Ich habe jetzt bei mir die Anzahl der Sendebefehle für alle Sendebefehle auf eins eingestellt und der Server friert weiterhin nach einer Zeit ein (unabhängig davon ob automatische Schaltvorgänge aufgrund von Bedingungen erfolgt sind oder ob er nur in Bereitschaft war)


    Hat sich bei dir mit dem Update etwas getan? Es wurde laut Changelog ja etwas gefixt.

    Was bleibt ist der nicht funktionierende Autostart. Selbst der im ersten Post genannte Umweg funktioniert nicht immer (erzeugt dann die identische fehlermeldung wie das shcd.sh skript im log) und ich muss den Serverdienst von Hand starten. Nicht schön, falls die weibliche Besetzung mal allein zu hause ist. Ein einfachen neustart des pi bekommt man noch irgendwie erklärt, mit dem Terminal braucht man in der Regel aber nicht anfangen. Und dann kann die Luft schnell mal dick werden.. :D

    Grüße


    Bei mir hat sich rein durch das update nichts verbessert, aber ich habe bei einem anderem Image das SHC in Kombination mit pilight für den Empfänger installiert und hier läuft das SHC mit allem was dazugehört (Sheduler, Schaltserver...) ohne Probleme. Ich denke inzwischen, das der erste Ansatz von agent bezüglich rcswitch nicht ganz verkehrt war.
    Schöne Grüße
    JD2K7
  • RE: Schaltserver stürzt ab

    rgarcia wrote:


    xerox wrote:


    Wie beendest du den SH und ST?


    erst mal mit ps -ef die PID der Prozesse raussuchen und dann mit


    Source Code

    1. sudo kill -9 HIERDIEPID


    PS: Ich nutze kein rcswitch und habe es auch nicht installiert


    Hi,
    damit hast du mir wirklich sehr geholfen, vielen Dank! Es ist tatsächlich genau wie bei dir, beim Autostart starten sheduler und sensortransmitter, nur der Schaltserver nicht.
    Starte ich anschließend den service shcd manuell, werden SH und ST ja nochmal mitgestartet (das hatte ich überhaupt nicht mehr bedacht). Somit liefen bei mir teils 2..3 SH und ST parallel, sehr schön mit ps -ef zu erkennen.
    Das darf natürlich nicht sein. Ich habe es noch nicht getestet (und weiß auch nicht, ob ich in nächster Zeit dazu komm), aber ich kann mir vorstellen dass das Problem der ersten Seite damit zusammenhängt.
    Ebenfalls erklären 2 SH, warum beim Auslösen von Ereignissen die an das Handy wifi gekoppelt sind, die Schaltelemente mehrmals ausgeführt wurden (z.B. doppelte push Benachrichtigungen) und warum das slow Profil des SH bei mir nicht funktionierte. Da auf meinem Handy ein frühes beta custom rom mit oft beklagten wlan abrissen läuft,  hatte ich das Problem eher in der Richtung vermutet.

    Grüße
  • RE: Schaltserver stürzt ab

    Perfekt das freut mich.
    Wenn wir jetzt noch dem Mysterium um den nur gelegentlich mit startenden Schaltserver auf die schliche kommen, können wir das Problem abhacken.

    Lösch doch mal alle exception und error logs aus den folgenden Ordnern:

    /var/www/shc/rwf/data/log/
    /var/www/shc/shc/data/log/

    Boote den Raspberry neu durch und schau in welchem Ordner Logs entstanden sind.
    Bei mir war anschließend wie im Beitrag erwähnt die exception.log unter rwf mit Fehlermeldungen gefüllt.

    PS: Ich glaube es liegt nach wie vor daran, dass das SHC zu schnell startet. Da kommt die Redis Datenbank nicht hinterher. Agent hatte dazu bereits ein Sleep eingebaut - nur scheint dieser nicht ganz auszureichen. Mag evtl. auch an den Raspberry Pi 2 liegen. Andernfalls kann ich mir nicht erklären wieso sich der SS händisch problemlos (ohne Fehlermeldungen) starten lässt.

    The post was edited 1 time, last by rgarcia ().

  • RE: Schaltserver stürzt ab

    Was ist dann für die Fehlermeldungen in der exception Log verantwortlich?

    Ich meine bei der Konfiguration der Schaltservers werde doch die Redisdaten verlangt.

    Evtl. gibt es da irgendwo eine Abhängigkeit die prüft ob der redis verfügbar ist und falls dies nicht der Fall ist den SS nicht startet.

    Könnte man ja ganz einfach testen indem mal SS abschießt dann redis und dann mal versucht den SS zu starten. Bin aber gerade unterwegs. Morgen dann ;)

    The post was edited 1 time, last by rgarcia ().

  • RE: Schaltserver stürzt ab

    rgarcia wrote:


    ...

    PS: Ich glaube es liegt nach wie vor daran, dass das SHC zu schnell startet.


    Hi

    Den Verdacht hatte ich auch schon. Allerdings nicht im Zusammenhang mit Redis, hierzu habe ich keine Fehlermeldung. Vielleicht eher mit dem Netzwerk an sich.

    Hier ein Auszug meiner /var/log/messages inklusive vor und nach dem fehlerhaften Schaltserver Autostart.


    Source Code

    1. [1;33mVerbindung zur Datenbank Fehlgeschlagen, erneuter Versuch in 10 Seekunden
    2. [0m//////////////////////////////////////////////////////////////////////////////////////////////////
    3. // System error
    4. //////////////////////////////////////////////////////////////////////////////////////////////////
    5. Datei:         lib/io/socketserver.class.php
    6. Zeile:         114
    7. Meldung:       "99: Cannot assign requested address"
    8. Klasse:        Exception
    9. Fehler Nummer: 1151
    10. Zeit:          24.06.2015 21:12:34
    11. //Trace///////////////////////////////////////////////////////////////////////////////////////////
    12. #0 /var/www/shc/shc/lib/switchserver/switchserversocket.class.php @ Line: 108 RWF\IO\SocketServer->startServer()
    13. #1 /var/www/shc/shc/data/commands/cli/switchservercli.class.php @ Line: 476 SHC\SwitchServer\SwitchServerSocket->run(RWF\Request\CliResponse)
    14. #2 /var/www/shc/shc/data/commands/cli/switchservercli.class.php @ Line: 87 SHC\Command\CLI\SwitchServerCli->executeCliCommand()
    15. #3 lib/request/abstractcommand.class.php @ Line: 77 SHC\Command\CLI\SwitchServerCli->executeCommand()
    16. #4 lib/request/requesthandler.class.php @ Line: 216 RWF\Request\AbstractCommand->execute(RWF\Request\CliRequest, RWF\Request\CliResponse)
    17. #5 lib/request/requesthandler.class.php @ Line: 129 RWF\Request\RequestHandler->handleCliRequest()
    18. #6 lib/request/requesthandler.class.php @ Line: 111 RWF\Request\RequestHandler->__construct('cli', '')
    19. #7 /var/www/shc/index.php @ Line: 25 RWF\Request\RequestHandler::handleRequest()
    20. #8 {main}
    21. Jun 24 21:12:35 Master kernel: [   15.082399] Adding 102396k swap on /var/swap.  Priority:-1 extents:2 across:2134012k SSFS
    22. [0;31mVerbindung zum Server "192.168.178.45:80" fehlgeschlagen
    23. [0m[1;33merneuter Versuch in 30 Sekunden
    24. [0mJun 24 21:12:45 Master kernel: [   25.182996] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
    25. connect: Network is unreachable
    Display All


    Kann es sein, dass zum Startversuch die eth0 Schnittstelle noch garnicht soweit ist? Immerhin steht der Eintrag erst 11 Sekunden nach der Fehlermeldung des SHC dort (21:12:34 --> 21:12:45)
    in der /var/log/syslog ist ersichtlich, dass bei einem Neustart um 21:12:27 die letzten Prozesse beendet werden und um 21:12:33 die ersten Prozesse starten. Wie erwähnt gegen 21:12:45 die eth0, um 21:12:49 wird erst die IP per DHCPCD bezogen. Dann kann doch der Server nicht schon um 21:12:34 vom SHC unter der Adresse gestartet werden, oder? :huh:

    Grüße

    The post was edited 1 time, last by xerox ().

  • RE: Schaltserver stürzt ab

    Ich werde morgen mal für einen bekannten einen komplett neuen pi 2 aufsetzen der heute gekommen ist und alles sauber installieren. Mal sehen wie die Sache da aus sieht. Aber ich geh doch davon aus, dass die meisten hier auch einen pi 2 verwenden, richtig? Läuft der autostart da sauber durch?
    Ich habe 3 pi 1b als slave, bei allen funktioniert es, nur der pi 2b master zeigt die murren.
  • RE: Schaltserver stürzt ab

    Also folgendes habe ich eben aus der /var/log/Messages Datei nach einem Neustart entnehmen können.

    Source Code

    1. Jun 25 13:47:18 raspberrypi03 kernel: [   11.809237] random: nonblocking pool is initialized
    2. ^[[1;33mVerbindung zur Datenbank Fehlgeschlagen, erneuter Versuch in 10 Sekunden
    3. ^[[0m//////////////////////////////////////////////////////////////////////////////////////////////////
    4. // System error
    5. //////////////////////////////////////////////////////////////////////////////////////////////////
    6. Datei:         lib/io/socketserver.class.php
    7. Zeile:         114
    8. Meldung:       "99: Cannot assign requested address"
    9. Klasse:        Exception
    10. Fehler Nummer: 1151
    11. Zeit:          25.06.2015 13:47:20
    12. //Trace///////////////////////////////////////////////////////////////////////////////////////////
    13. #0 /var/www/shc/shc/lib/switchserver/switchserversocket.class.php @ Line: 108 RWF\IO\SocketServer->startServer()
    14. #1 /var/www/shc/shc/data/commands/cli/switchservercli.class.php @ Line: 476 SHC\SwitchServer\SwitchServerSocket->run(RWF\Request\CliResponse)
    15. #2 /var/www/shc/shc/data/commands/cli/switchservercli.class.php @ Line: 87 SHC\Command\CLI\SwitchServerCli->executeCliCommand()
    16. #3 lib/request/abstractcommand.class.php @ Line: 77 SHC\Command\CLI\SwitchServerCli->executeCommand()
    17. #4 lib/request/requesthandler.class.php @ Line: 216 RWF\Request\AbstractCommand->execute(RWF\Request\CliRequest, RWF\Request\CliResponse)
    18. #5 lib/request/requesthandler.class.php @ Line: 129 RWF\Request\RequestHandler->handleCliRequest()
    19. #6 lib/request/requesthandler.class.php @ Line: 111 RWF\Request\RequestHandler->__construct('cli', '')
    20. #7 /var/www/shc/index.php @ Line: 25 RWF\Request\RequestHandler::handleRequest()
    21. #8 {main}
    22. Jun 25 13:47:20 raspberrypi03 kernel: [   14.302532] Adding 102396k swap on /var/swap.  Priority:-1 extents:2 across:2162644k SSFS
    23. Jun 25 13:47:21 raspberrypi03 kernel: [   15.787611] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
    24. ^[[0;31mVerbindung zum Server "192.168.1.30:80" fehlgeschlagen
    25. ^[[0m^[[1;33merneuter Versuch in 30 Sekunden
    26. ^[[0m
    Display All


    Den Fehler habe ich bisher nur durch Neustarten des Pi's reproduzieren können. Später werde ich mal prüfen wie es aussieht wenn ich den Start des SHC's verzögere.

    [hr]
    Update: Ich habe nun in die /etc/init.d/shcd Datei einen sleep von 10 eingebaut. In den 5 darauffolgenden Neustarts ist der SS stets erfolgreich mitgestartet.

    The post was edited 1 time, last by rgarcia ().

  • RE: Schaltserver stürzt ab

    rgarcia wrote:


    PS: Ich glaube es liegt nach wie vor daran, dass das SHC zu schnell startet. Da kommt die Redis Datenbank nicht hinterher. Agent hatte dazu bereits ein Sleep eingebaut - nur scheint dieser nicht ganz auszureichen. Mag evtl. auch an den Raspberry Pi 2 liegen. Andernfalls kann ich mir nicht erklären wieso sich der SS händisch problemlos (ohne Fehlermeldungen) starten lässt.


    Ich habe auf meinem Pi 1B meinen Master laufen und da funktioniert alles ohne Probleme. Schaltserver und Sheduler starten nach Neustart wie gewollt. Also wahrscheinlich ein Problem mit dem Pi 2?
  • RE: Schaltserver stürzt ab

    Das kann ich dir nicht sagen. Bei Xerox und mir ist es jedenfalls so. Xerox wollte heute bei einem bekannten einen Pi 2 mit SHC installieren. Warten wir mal ab was sein Ergebnis bei diesem ist. Generell denke ich aber nicht, das wir zwei die einzigen im Forum sind, die ein Pi 2 verwenden mit SHC verwenden ;)

    The post was edited 1 time, last by rgarcia ().

  • RE: Schaltserver stürzt ab

    Hi
    Es gibt gutes und schlechtes, aber auf jeden Fall neues.
    1. der sleep von 10 Sekunden im shcd skript hat auch mein Autostart Problem gelöst. Guter Tipp gewesen! (Mehrfache Neustarts durchgeführt. Jedes mal stand der Eintrag zur eth0 Schnittstelle VOR der Meldung des shc Servers in der var/log/messages. Das war das gute.
    Das schlechte: Ein komplett neuer pi2 (gestern das ganze Programm von reich**t erhalten) mit einer sauberen shc Installation hat das identische Problem mit dem Autostart. Ich habe lediglich die 2 noch fehlenden Imports nachgetragen und den Tippfehler mit dem smarthomedevice im PCC beseitigt. Also ist der nicht startende SS beim pi2 reproduzierbar. Auch hier hat der sleep 10 Abhilfe geschafft.

    Mit welchem raspbian image flashst du denn, agent? Ich glaube meines ist vom 5.5...

    Grüße

    The post was edited 1 time, last by xerox ().

  • RE: Schaltserver stürzt ab

    xerox wrote:


    Hi
    Es gibt gutes und schlechtes, aber auf jeden Fall neues.
    1. der sleep von 10 Sekunden im shcd skript hat auch mein Autostart Problem gelöst. Guter Tipp gewesen!  (Mehrfache Neustarts durchgeführt.   Jedes mal stand der Eintrag zur eth0 Schnittstelle VOR der Meldung des shc Servers in der var/log/messages. Das war das gute.
    Das schlechte: Ein komplett neuer pi2 (gestern das ganze Programm von reich**t erhalten) mit einer sauberen shc Installation hat das identische Problem mit dem Autostart. Ich habe lediglich die 2 noch fehlenden Imports nachgetragen und den Tippfehler mit dem smarthomedevice im PCC beseitigt. Also ist der nicht startende SS beim pi2 reproduzierbar. Auch hier hat der sleep 10 Abhilfe geschafft.

    Mit welchem raspbian image flashst du denn, agent? Ich glaube meines ist vom 5.5...

    Grüße


    Kanst du das shcd datei mal hier laden damit man sie wo du es eingebaut hasst
  • RE: Schaltserver stürzt ab

    @jsp-email das sleep 10 kannst du einfach eine Zeile über das do_start() packen.

    Ich gehe mal davon aus das du das gleiche Problem wie xerox und ich hast!?

    @xerox eben deswegen hatte ich aus dem message log den Eintrag in welchem der start des interfaces gezeigt wird mit kopiert.

    PS: Das mit sleep ist keine saubere Lösung, weiss momentan jedoch noch nicht wie man das eleganter löst :/
  • RE: Schaltserver stürzt ab

    Wenn das die Lösung sein sollte, kann man das über Run Level machen. Es kann sein das der shcd ein niedrigeres runlevel als Redis und/oder das Netzwerk hat.Wie gena man die setzt und beeinflusst bin ich aber auch nicht im Bilde, da muss ich auch erstmal schauen.
    Das Starscript habe ich auch nicht selbst erstellt, das wurde mal von einem User im Raspberry Pi Forum geschrieben und von mir nur auf die neueren Versionen angepasst.
  • RE: Schaltserver stürzt ab

    Dieses Thema verfolge ich seit einiger Zeit am Rande. Am Rande deswegen, weil ich die angegebenen Fehler nicht nachvollziehen kann.

    Ich benutze zwei Raspberry2, beide mit WLAN EDIMAX. Einer läuft als reiner Master, ohne das GPIO's z. Z. genutzt werden, der andere nur zu Testzwecken.

    Kann es sein, dass bei mir die Fehler nicht auftreten, da das WLAN längere Zeit zum Verbinden benötigt als ein LAN Kabel?

    Vielleicht hilft euch diese Aussage.

    Am Anfang dieses Threads geht es wohl darum, dass wenn mehrere Schaltserver im System laufen, es zu Abstürzen kommt. Mir ist jetzt nicht ganz klar, geht es um mehrere Schaltserver auf einem Pi, oder um mehrere laufende bei einer Verteilten Installation?

    Bei einer verteilten Installation sollten doch laufende Schaltserver und Sheduler auf den Slave's das ganze System nicht beeinflussen, zumindest solange nicht bis auf den Slave's Schaltbare Elemente in der Weboberfläche eingefügt wurden.

    Ich habe jetzt einen Master und 4 Slave's am laufen und auf allen läuft ein Schaltserver und ein Sheduler. Ich konnte nichts negatives feststellen.

    Auf meinem fünften Testraspi läuft noch obendrein ein Abbild des Masters, auch dieser beeinflusst das gesamte System nicht. Allerdings benutze ich auch keine "toggle" Funktion. Da könnte ich mir eine Beeinflussung dann vorstellen.

    Wenn dieser Beitrag an eurer Diskussion vorbei geht, dann vergesst ihn einfach.
    SHC Master B2+ WLAN sowie 1 Slave B2+, 2 Slave B+ und 2 Slave Raspi B. 5x Pi Cam; Imac mit OSX El Capitan; Iphone 6 plus; Ipad mini; Lenovo Android Tablet.
  • RE: Schaltserver stürzt ab

    rmjspa wrote:


    Dieses Thema verfolge ich seit einiger Zeit am Rande. Am Rande deswegen, weil ich die angegebenen Fehler nicht nachvollziehen kann.

    Ich benutze zwei Raspberry2, beide mit WLAN EDIMAX. Einer läuft als reiner Master, ohne das GPIO's z. Z. genutzt werden, der andere nur zu Testzwecken.

    Kann es sein, dass bei mir die Fehler nicht auftreten, da das WLAN längere Zeit zum Verbinden benötigt als ein LAN Kabel?

    Vielleicht hilft euch diese Aussage.

    Am Anfang dieses Threads geht es wohl darum, dass wenn mehrere Schaltserver im System laufen, es zu Abstürzen kommt. Mir ist jetzt nicht ganz klar, geht es um mehrere Schaltserver auf einem Pi, oder um mehrere laufende bei einer Verteilten Installation?

    Bei einer verteilten Installation sollten doch laufende Schaltserver und Sheduler auf den Slave's das ganze System nicht beeinflussen, zumindest solange nicht bis auf den Slave's Schaltbare Elemente in der Weboberfläche eingefügt wurden.

    Ich habe jetzt einen Master und 4 Slave's am laufen und auf allen läuft ein Schaltserver und ein Sheduler. Ich konnte nichts negatives feststellen.

    Auf meinem fünften Testraspi läuft noch obendrein ein Abbild des Masters, auch dieser beeinflusst das gesamte System nicht. Allerdings benutze ich auch keine "toggle" Funktion. Da könnte ich mir eine Beeinflussung dann vorstellen.

    Wenn dieser Beitrag an eurer Diskussion vorbei geht, dann vergesst ihn einfach.


    Hi,

    du hast schon recht, das Thema hat sich inzwischen von der ursprünglichen Fragestellung (ABstürzende Schaltserver) weit entfernt. Ich denke die diskussion über den Autostart sollte man in einen eigenen Thread verlagern.

    Ich werde am Wochenende mal versuchen, ob das eigentliche Thema, das Abstürzen des Schaltservers bei bestimmten Dosen,Aktivitäten,Ereignissen, verschwunden ist. Es könnte damit zutun gehabt haben, dass auf dem einen master mehrere SH gleichzeitig liefen. Das wurde ja aufgedeckt durch rgarcias Hinweis mit dem "ps -eF" Befehl. Dann könnte man die Diskussion an dieser Stelle beenden und sich um den Autostart kümmern.

    @rmjspa: Ich hatte nie mehrere Schaltserver auf EINEM system laufen, nur mehrere sh und st, da diese beim autostart mitgestartet sind und ich anschließend den befehl "service shcd" manuell gestartet habe. dann wurden die nochmal mitgestartet und liefen mehrfach. So wie ich Agent verstanden hab, und so funktioniert es auch bei mir, verwalte ich alles vom master aus (hier läuft st, ss und sh) und auf den slaves ist der sh ganz abgeschaltet (php index.php -sh -c). ss läuft mit der slave ip und st mit der master ip. im master werden dann die slaves als schaltserver eingetragen und die sensorpunkte werden automatisch erstellt, da die slaves die daten schicken. die weboberflächen der slaves sind komplett leer. Ich hab hier einfach das gleiche System draufgebügelt wie auf einem master, mit redis, webserver ... da ich zur zeit danach nicht auch noch gucken kann. die Mehrbelastung ist mir relativ egal, da auf dem pi einzig das shc läuft, sonst nix. Die Redundanz ist mir natürlich bewusst und sobald eine Installation der slaves ohne redis und co stabil funktioniert, werde ich mich damit befassen, aber frühestens, nachdem ich in 2..3 Wochen wieder mehr Zeit hab.

    Grüße

    The post was edited 1 time, last by xerox ().

  • RE: Schaltserver stürzt ab

    @rmjspa: Ich hatte nie mehrere Schaltserver auf EINEM system laufen, nur mehrere sh und st, da diese beim autostart mitgestartet sind und ich anschließend den befehl "service shcd" manuell gestartet habe. dann wurden die nochmal mitgestartet und liefen mehrfach. So wie ich Agent verstanden hab, und so funktioniert es auch bei mir, verwalte ich alles vom master aus (hier läuft st, ss und sh) und auf den slaves ist der sh ganz abgeschaltet (php index.php -sh -c). ss läuft mit der slave ip und st mit der master ip. im master werden dann die slaves als schaltserver eingetragen und die sensorpunkte werden automatisch erstellt, da die slaves die daten schicken. die weboberflächen der slaves sind komplett leer. Ich hab hier einfach das gleiche System draufgebügelt wie auf einem master, mit redis, webserver ... da ich zur zeit danach nicht auch noch gucken kann. die Mehrbelastung ist mir relativ egal, da auf dem pi einzig das shc läuft, sonst nix. Die Redundanz ist mir natürlich bewusst und sobald eine Installation der slaves ohne redis und co stabil funktioniert, werde ich mich damit befassen, aber frühestens, nachdem ich in 2..3 Wochen wieder mehr Zeit hab.


    Ja, genau so ist es bei mir auch. Der einzige Unterschied ist, dass ich den Sheduler auf den Slave's nicht ausgeschaltet habe, da bei mir auch die Weboberflächen der Slave's leer sind, bis auf einen Testraspi, stören die laufenden Sheduler m.E. auch nicht wenn sie laufen.
    Die Mehrbelastung durch Redis und Apache stören mich auch nicht.

    Was mir allerdings auffällt ist, das der Prozess "php" oft eine CPU Belastung von bis zu etwa 98% hat (B und B+). Woher genau diese kommt, und ob man da etwas ändern kann, weiß ich allerdings nicht. Auch der 1 wirrer master hat eine hohe Belastung. Der Rest ist eigentlich zu vernachlässigen. Bei mir laufen noch 3 Picam's eine am Master und zwei auf den Slave's. Auf dem Master (Raspi Model2) läuft noch Geofancy. Ansonsten auch nur der SHC. Nur so zur Info.
    SHC Master B2+ WLAN sowie 1 Slave B2+, 2 Slave B+ und 2 Slave Raspi B. 5x Pi Cam; Imac mit OSX El Capitan; Iphone 6 plus; Ipad mini; Lenovo Android Tablet.
  • RE: Schaltserver stürzt ab

    Hallo zusammen,

    ich habe durchgehend das Problem das mein Schaltserver abstürzt. Hatte erst die Version vor 2.2.2, damit auch schon das Problem. Durch ein Update hat sich die Situation nicht verbessert. Wo könnte ich denn mit dem forschen anfangen ? Benutze pilight. Wenn das SHC nichts mehr macht, meldet das Logfile das der Schaltserver nicht laufen wuerde. Mit Pilight kann ich noch Befehle absetzen. Wennich den Schaltserver neu starte hält das ne Zeit. Einige Stunden, genauer konnte ich es noch nicht eingrenzen, dann ist wieder nix mehr. Zum Einsatz kommt nen raspberry2.

    -hasturo