nach Aktivität kein schalten mehr möglich

  • nach Aktivität kein schalten mehr möglich

    Hallo zusammen,

    habe gestern mal meinen kompletten rpi neuinstalliert und soweit läuft auch alles wieder.
    jedoch besteht anscheinend ein fehler/problem bei den Aktivitäten
    ich habe 2 elro steckdosen angelegt, diese habe ich getestet und alles funktionierte gut (ein und ausschalten, beliebig oft).
    dann habe ich eine aktivität angelegt und beide steckdosen dieser aktivität zugeordnet.
    Dann habe ich diese Aktivität einmal eingeschaltet und ab diesem zeitpunkt konnte ich keine steckdose mehr schalten (sie gingen weder an, noch aus. Auch die Aktivität funktioniert nicht mehr.

    Ich habs dann mit rcswitch aus der konsole probiert und damit ging alles wunderbar.
    Dann habe ich die Aktivität gelöscht und den rpi rebootet und dann ließen sich die steckdosen wieder aus shc schalten. Aktivität angelegt, einmal geschaltet und dann war wieder schluß.

    Kann mir da jemand helfen?

    Gruß Christian
  • RE: nach Aktivität kein schalten mehr möglich

    Hört sich ganz stark hiernach an (zumindest das, wie du es beschreibst, hatte ich bei mir auch mal gehabt):

    http://rpi-controlcenter.de/showthread.php?tid=351

    Versuch mal, den SS im debug laufen zu lassen und dann die Aktivität auszuführen.
  • RE: nach Aktivität kein schalten mehr möglich

    hallo zusammen, in die logs habe ich leider nicht mehr geschaut, da es schon 4 uhr morgens war und um 6 uhr der Wecker klingelte :) aber ich werds heut abend mal probieren und dann die logs anschauen.

    zur konfiguration: frisches raspbian, shc aufgesetzt nach Anleitung(https://github.com/agent4788/SHC_Framework/wiki/Raspberry-Pi), shc, schaltserver, etc alles nur auf einem rpi der per lan mit der fritzbox verbunden ist.

    lief mit der 2.0 (habe die sd karte noch) einwandfrei.

    gruß christian
  • RE: nach Aktivität kein schalten mehr möglich

    also, hab den schaltserver jetzt im debug laufen. beim ersten mal ausschalten der aktivität sehe ich
    sudo /opt/rcswitch-pi/send 00001 2 0
    sudo /opt/rcswitch-pi/send 00001 1 0
    sudo /opt/rcswitch-pi/send 00001 2 0
    sudo /opt/rcswitch-pi/send 00001 1 0


    und wenn ich dann versuche sie wieder anzuschalten passiert gar nichts mehr auf der konsole

    also im exception und error log ist nichts zu sehen :(

    The post was edited 1 time, last by christianruby ().

  • RE: nach Aktivität kein schalten mehr möglich

    ich hab da eigentlich alles gelesen.
    ps -ef|grep shc

    pi       10709 10320 45 22:37 pts/0    00:07:00 php index.php app=shc -ss -d
    root     10718     1  1 22:37 pts/1    00:00:10 /usr/bin/php /var/www/shc/index.php app=shc -sh
    root     10720     1 38 22:37 pts/1    00:05:49 /usr/bin/php /var/www/shc/index.php app=shc -st
    pi       10893 10514  0 22:52 pts/1    00:00:00 grep --color=auto shc

    mehrere prozesse laufen da auch nicht.
    oder habe ich etwas überlesen was das problem behebt?

    habe auch das sleep im startscript eingebastelt.

    hatte jetzt nochmal alles gelesen und habe nun doch noch was gefunden. habe jetzt die sendevorgänge der einzelnen steckdosen auf 1 gesetzt und dann ging es.
    habe sie jetzt wieder auf 2 und die letzte auf 3 gesetzt und es geht nicht mehr.
    hmmm warum auch immer :) jetzt hab ich beide auf 2 und alles ist gut

    The post was edited 1 time, last by christianruby ().

  • RE: nach Aktivität kein schalten mehr möglich

    Hi,
    ich bin da auch nicht mehr weiter nachgegangen, da es auch mit einem Sendevorgang zuverlässig schaltet. Woran es letzten endes lag, weiß ich aber immer noch nicht. Ich wollte das immer mal weiter testen, aber wie das so ist mit der Zeit. :D

    Ich wollte als nächstes mal alle Dosen auf pilight umstellen. Ob es daran liegt, weiß ich natürlich auch nicht.