Temperatursensor DS18B20

  • Moinsen,

    nachdem meine SD-Karte kaputt gegangen ist, bin ich dabei SHC 2.2.7 unter jessie zu installieren.

    Ein Problem macht der Dallas DS1820:
    Der Sensor wird erkannt und gibt Werte aus:

    cat /sys/bus/w1/devices/10-000802b57556/w1_slave
    35 00 4b 46 ff ff 06 10 5c : crc=5c YES
    35 00 4b 46 ff ff 06 10 5c t=26375

    die /boot/config.txt sieht am Ende so aus:

    dtoverlay=w1-gpio


    die /etc/modules:
    ist leer.

    Der Sensortransmitter läuft!
    php index.php app=shc -ds
    Status der Dienste:
    Schaltserver: läuft
    Sensor Sender: läuft

    -------------

    Ich habe auch schon mit vielen Variationen der config.txt und modules gearbeitet (hier mal auskommentiert):
    /boot/config.txt
    #dtoverlay=w1-gpio,gpiopin=4,pullup=on

    in der /etc/modules
    #w1-gpio pullup=1
    #w1-therm


    ABER im SHC wird der Sensor nicht angezeigt... Liegt das an Jessie-lite?

    Muss ich irgendwie berücksichtigen, dass ich SHC nur unter "https://DYNDNS/shc/index.php?app=shc" (also Port 443) anspreche?


    Danke und Gruß Ralf
  • Moin zusammen,

    leider zeigt SHC den Sensor nicht an... Ok. Ich gehe die installationsliste noch mal Schritt für Schritt durch. Vielleicht habe ich doch etwas vergessen....


    Schönen Sonntag noch!

    Ralf

    PS: Ich bin einen Schritt weiter:

    php index.php app=shc -st -d
    Typ: DS18x20
    Sensor Punkt Id: 99
    Sensor ID: 10-000802b57556
    Temeratur: 23.375°C
    -----------------------------------------------------------------------------
    Verbindung zum Server "127.0.0.1:80" fehlgeschlagen
    erneuter Versuch in 30 Sekunden

    The post was edited 1 time, last by Bastel_Ralf: Ergänzung ().