Version 2.2.3, Schaltserver startet nicht

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Version 2.2.3, Schaltserver startet nicht

    Nach der Neuinstallation der Version 2.2.3 startet der Schaltserver nicht mehr, weder auf dem Master noch auf dem Slave.
    Beim manuellen Start erscheint folgender Fehler:

    Source Code

    1. PHP Fatal error:  Call to a member function getValue() on null in /var/www/shc/rwf/lib/core/rwf.class.php on line 396

    Ein Logfile ist unter /var/www/shc/rwf/data/log nicht vorhanden.
  • RE: Version 2.2.3, Schaltserver startet nicht

    Gleiches Problem auch bei mir:

    Wenn ich nach dem Neustart versuche den Schaltserver manuell zu starten, kommt folgende Fehlermeldung:

    Source Code

    1. //////////////////////////////////////////////////////////////////////////////////////////////////
    2. // System error
    3. //////////////////////////////////////////////////////////////////////////////////////////////////
    4. Datei: lib/io/socketserver.class.php
    5. Zeile: 114
    6. Meldung: "98: Address already in use"
    7. Klasse: Exception
    8. Fehler Nummer: 1151
    9. Zeit: 20.09.2015 11:55:22
    10. //Trace///////////////////////////////////////////////////////////////////////////////////////////
    11. #0 /var/www/shc/shc/lib/switchserver/switchserversocket.class.php @ Line: 122 RWF\IO\SocketServer->startServer()
    12. #1 /var/www/shc/shc/data/commands/cli/switchservercli.class.php @ Line: 497 SHC\SwitchServer\SwitchServerSocket->run(RWF\Request\CliResponse)
    13. #2 /var/www/shc/shc/data/commands/cli/switchservercli.class.php @ Line: 108 SHC\Command\CLI\SwitchServerCli->executeCliCommand()
    14. #3 lib/request/abstractcommand.class.php @ Line: 77 SHC\Command\CLI\SwitchServerCli->executeCommand()
    15. #4 lib/request/requesthandler.class.php @ Line: 216 RWF\Request\AbstractCommand->execute(RWF\Request\CliRequest, RWF\Request\CliResponse)
    16. #5 lib/request/requesthandler.class.php @ Line: 129 RWF\Request\RequestHandler->handleCliRequest()
    17. #6 lib/request/requesthandler.class.php @ Line: 111 RWF\Request\RequestHandler->__construct('cli', '')
    18. #7 /var/www/shc/index.php @ Line: 25 RWF\Request\RequestHandler::handleRequest()
    19. #8 {main}
    20. //////////////////////////////////////////////////////////////////////////////////////////////////
    21. // PHP Warning
    22. //////////////////////////////////////////////////////////////////////////////////////////////////
    23. Datei: lib/error/error.class.php
    24. Zeile: 746
    25. Meldung: fopen(/var/www/shc/rwf/data/log/exception.log): failed to open stream: Permission denied
    26. Fehler Nummer: 2
    27. Zeit: 20.09.2015 11:55:22
    28. //Trace///////////////////////////////////////////////////////////////////////////////////////////
    29. #0 @ Line: 0 RWF\Error\Error->handlePhpError(2, 'fopen(data/log/exception.log): failed to open stream: Permission denied', 'lib/error/error.class.php', 746, Array(9))
    30. #1 lib/error/error.class.php @ Line: 746 fopen('data/log/exception.log', 'a')
    31. #2 lib/error/error.class.php @ Line: 342 RWF\Error\Error->logError('exception.log', 'System Exception', 'lib/io/socketserver.class.php', 114, '"98: Address already in use"', 1151, Array(8), Array(1))
    32. #3 @ Line: 0 RWF\Error\Error->handleException(Exception)
    33. #4 {main}
    Display All


    ps -ef zeigt den sh und ss als running an:

    Source Code

    1. root 2408 1 8 11:58 pts/0 00:00:00 /usr/bin/php /var/www/shc/index.php app=shc -sh
    2. root 2409 1 4 11:58 pts/0 00:00:00 /usr/bin/php /var/www/shc/index.php app=shc -ss

    The post was edited 1 time, last by rgarcia ().

  • RE: Version 2.2.3, Schaltserver startet nicht

    rgarcia wrote:


    Moin, als Fehlermeldung kommt die selbe wie auch vorher schon. Address already used was so aber eigentlich nicht sein kann :-/


    Das ist ein anderes Problem, wie hier schon erwähnt: Klick
    Der Dienst läuft einfach schon und wird wahrscheinlich beim restart nicht ordnungsgemäß beendet. Dann ist die Adresse eben, wie der Fehler besagt, schon in Verwendung.
  • RE: Version 2.2.3, Schaltserver startet nicht

    Moin groovy,

    das kann ich bei mir leider nicht bestätigen.
    Nach dem sudo service shcd stop wird kein SHC Dienst mehr in ps -ef gelistet.
    Demnach sollte meiner Meinung nach der Dienst mit sudo service shcd start problemlos starten können - was er jedoch nicht tut.
    Oder sieht es bei dir da anders aus?
    Sobald ich wieder zu Hause bin werde ich jedenfalls sicherheitshalber noch mal drüber gucken ;)
  • RE: Version 2.2.3, Schaltserver startet nicht

    Hab es noch nicht nach Hause geschafft. Daher hier nun Screenshots der Putty-Sitzung vom Handy aus. Eventuell mache ich ja auch was falsch 😶
    [hr]
    Anbei noch die exception.log
    @Groove: Funktioniert mein Anliegen bei dir ohne Probleme? Ich würde gerne wissen ob nur ich das Problem habe :-/
    Files

    The post was edited 1 time, last by rgarcia ().