[erledigt] LDR und Operationsverstärker UA741cn

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [erledigt] LDR und Operationsverstärker UA741cn

      Hallo zusammen,

      ich brauche mal Hilfe von Hardwareprofis...

      Ich wollte einen 2.LDR nutzen In Anlehung an meinen Post von hier wollte ich loslegen. Leider gab es den OP TLC3702 nicht mehr und der Fachhändler gab mir einen UA741cn mit dem Hinweis dass dieser genauso ginge.
      Schön und gut. Nach Studium des Datenblattes (Link) habe ich die Anschlüsse wie im Bild unten angeschlossen...

      Ihr ahnt es schon.. Es geht nicht. Aber warum nicht?


      PS die eingekreisten Zahlen sind die PINS am OP.

      Danke Ralf
    • Ich bekomme hier noch einen Floh!!!!

      Schönen Tag allen zusammen...

      So - bislang fast alles gut. Die Änderung der Pins hat geklappt. Gnd ist Pin 4; + ist an Pin7 mit 3,3V / 5V. Mit 5V bekomme ich einen zu großen Output (knapp 5V), die ich nicht an die Pi weitergeben möchte.

      Mit 3V bekomme ich immer Outwerte von 2,7V bis minimal 1,6V. Das reicht nicht für die Unterscheidung Low/High.... Ich hab nun soooo viel herum gebastelt, dass ich nicht mehr ein noch aus weiß. Zu den anderen Angaben: Für die Spannungsteiler habe ich jeweils 10k Ohm und der LDR geht von 0,5kOhm bis 30kOhm.
      Der Poti ist mit 500K etwas doof einzustellen es geht aber mit etwas "Gefühl".

      Das Einstellen habe ich so gemacht, dass ich versucht habe bei (normaler Beleuchtung) zwischen den Punkte 2 und 3 am UA in etwa die gleiche Spannung einzustellen (Poti); also eine Spannungsdifferenz von knapp +- Null).

      Aber ich bekomme es nicht hin, dass ich entweder für Low von 0-0,8V und High für 1,3V bis liege. Gibt es da ggf. eine andere Schaltung oder sollte ich auf einen anderen Operationsverstärker zurückgreifen (ich habe von einem LM358 gelesen...)

      Völlig genervt... Aber hier werde ich gleich bestimmt wieder aufgebaut.

      Danke!
    • Boah... Zuerst einmal: Einen schönen guten Morgen zusammen.

      Danke für den Tipp mit der Schmitt-Trigger Schaltung. Klappt ganz gut, allerdings habe ich diese Seite gefunden: Link Da ging es ganz gut.

      Frage an die Profis: Langsam glaube ich, dass der UA741 kaputt ist.... Alle Schaltungen klappen soweit - nur dass ich als LOW immer 1,6V-1,8V bekomme... Egal ob mit 5V Eingang oder 3,3V; wobei der Max-Output dann jeweils knapp 5V bzw. 3V sind.... Kann das sein, dass der OP mittlerweile kaputt ist????

      Ich bin niemals über 8V gegangen, als ich an der Messstation gearbeitet habe und mit der Pi gehen max. 5V.

      Nachtrag: Ich habe soeben die beiden Bausteine 1:1 ausgetauscht und kein anderes Ergebnis erhalten. D.h. entweder sind beide kaputt oder ich! 8o

      Es ist zum Verrückt werden. Ich werde Montag mal gucken, ob es andere OP`s gibt.. Obwohl es dadurch nicht besser wird. Langsam verliere ich die Lust.....

      Nein - nicht aufgeben. Weiter kämpfen.

      The post was edited 1 time, last by Bastel_Ralf ().

    • Mir ist jetzt nicht bekannt, ab welcher Voltzahl der Raspi ein Low bzw. High erkennt.

      Der einfachste Versuch wäre ein Ohmscher Spannungsteiler am GPIO Eingang 50:50 Also mal 2 10 Kohm probieren. Wenn Du ein 10 oder 20 K poti hast könntest Du mit den Werten auch experimentieren. Und mit dem Multimeter mal messen ab wann eine sichere Unterscheidung statt findet.
      Die andere Möglichkeit wäre eine Transistorstufe nach zuschalten. Das würde auf jeden Fall zum Erfolg führen. Welche Werte als Widerstände da jetzt sinnvoll wären kann ich dir jetzt nicht sagen. Dafür bin ich zu lange aus der Materie. Google sollte da aber behilflich sein.

      Vielleicht mit "Transistor als Schalter" probieren.
      SHC Master B2+ WLAN sowie 1 Slave B2+, 2 Slave B+ und 2 Slave Raspi B. 5x Pi Cam; Imac mit OSX El Capitan; Iphone 6 plus; Ipad mini; Lenovo Android Tablet.
    • Bei mir habe ich einen LDR mit selbsterstellter Platine seit ca. 1 Jahr am laufen.
      Spannungsversorgung beträgt 5 Volt.
      LDR ist mit einer ca. 20 cm Verlängerung mit der Platine verbunden.
      Die LDR Platine befindet sich an einer ESP12 Schaltserver Platine.
      Data Ausgang ist direkt am ESP Gpio angeschlossen.
      Images
      • LDR.JPG

        74.31 kB, 532×771, viewed 137 times
      Kann besser Hardware als Software !
    • @Bastel_Ralf
      Ich habe mir noch einmal das Datenblatt angeschaut. Der 741 benötigt bei einer symmetrischen Spannungsversorgung min. +/- 5V. Bei einer asymmetrischen Spannungsversorgung, die Du hast, brauchst Du glaube ich mindestens 10V. Versuche deine Schaltung mit z.B. 12V zu betreiben, dann müsste es funktionieren. Du bekommst bei High natürlich ca. 12V, aber die kann man über einen Spannungsteiler an ein GPIO führen.
    • Hey Leute,

      ich habe mich heute noch einmal etwas schlau gemacht: Es liegt anscheinend wirklich an der Versorgungsspannung +5V / 0 V sind zu wenig; außerdem habe ich etwas mit dem Offset-Null "gespielt" diese müssten laut Datenblatt unter Gnd liegen. Daher habe ich zwischen Pin 4 des UA und GND noch einen kleinen Widerstand gesteckt; so dass Offset-Null an GND etwas negativer ist (also V--) als Pin4.

      Damit ist die Minimale Spannung am OUT (Pin6) dann auf 0,2V gefallen und MAX auf 2,5V... Alles etwas sehr aufwendig geworden. Ich teste das morgen noch mal nachdem ich das auf ein Platine gelötet habe. Boah das war eine schwere Geburt. Wenn es alles klappt schicke ich noch einmal eine Schaltung rum.

      @premo: Du arbeitest auf deiner Platine mit einem CA3130 oder? Da ist auch ein Offset Null dran; klappt das problemlos oder musstest du noch was einstellen?

      Gruß Ralf
    • Bastel_Ralf wrote:

      @premo: Du arbeitest auf deiner Platine mit einem CA3130 oder? Da ist auch ein Offset Null dran; klappt das problemlos oder musstest du noch was einstellen?
      Ja, auf der Platine ist ein CA3130.
      Mit dem Poti kann ich Schaltpunkt einstellen.
      Bei eintreten der Dämmerung geht der Ausgang auf LOW
      Data Ausgang (5 V) ist mit dem Gpio vom ESP12 verbunden.
      Läuft bei mir schon ca. 1 Jahr.
      Man könnte noch einen Widerstand zwischen Data und Gpio setzen.
      Images
      • LDR 2.JPG

        78.61 kB, 878×544, viewed 138 times
      Kann besser Hardware als Software !
    • Ahrg...

      Ich habe mit dem UA aufgegeben... Beim Aufräumen fällt mir ein LN324n in die Hand, die ich früher mal für eine Lüftersteuerung gekauft habe... Also noch mal kurz ran und ...... Es klappt mit auf Anhieb! Da der LN324n ganze 4 OPs enthält kann ich jetzt gleich 4 LDR`s verbauen!!!!!

      Wenn ich fertig bin poste ich noch mal in "HardwareListe" mit Bild und Text und Schaltplan!

      Danke an Alle, die mich (mal wieder) so fürsorglich Betreut haben. "Betreutes Basteln hier"...

      Ralf ... Ich schließe das Thema hiermit...