Raspberry 3 - Download Image funkt nicht

  • Installation

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Raspberry 3 - Download Image funkt nicht

    Hallo zusammen,

    da habe ich gerade meinen neuen Raspberry 3 ausgepackt und auf eine SD Karte das vorhandene 227 Image aufgespielt - und jetzt funktioniert das einfach nicht :)

    Auf dem Monitor wird nur ein buntes Bild ausgegeben und die Lan Buchse bleibt überhaupt dunkel...

    Hm,... any Hints?
  • Das kann grundsätzlich mehrere Ursachen haben. Fest steht jedenfalls, dass der Pi von der SD-Karte nicht booten kann.

    Du könntest jetzt folgendes probieren. Wenn du noch einen Pi 2 zur Verfügung hast, dann kannst du die Karte einfach mal in diesem Probieren. Wenn sie dort läuft, ist die SD-karte wohl schon mal in Ordnung. In dem Fall könnte es sein, dass das Jessie-Image auf dem das Image basiert doch zu alt ist.
    Wenn sie dort nicht läuft, könnte das Image fehlerhaft auf die Karte übertragen worden sein, also noch mal draufspielen. Ist das auch nicht der Fall, könnte sogar die SD-karte beschädigt oder inkompatibel sein. Dann also eine andere Karte probieren.

    Hast du keinen Pi 2 zur Hand, so kannst du z.B. mal von hier mal ein aktuelles frisches Jessie ziehen, und das mal ausprobieren. Läuft das, dann liegt es wahrscheinlich wieder an dem fertigen Image. Dann kannst du es noch mal neu aufspielen und versuchen. Geht das auch wieder nicht, dann ist es wohl zu alt. Geht aber auch das original Jessie nicht, dann würde ich wirklich mal eine andere SD-Karte probieren.
    Gruß Dieter
    --------------
    Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.
  • Kann ich mir nicht vorstellen, dass jemand Interesse daran hat. Es gibt ja nur zwei Möglichkeiten, entweder das Image geht und es liegt an Deinem RPi oder SD und die andere, das was mit dem download nicht stimmt.

    Hast Du denn den Rat von Dieter befolgt?
    SHC Master B2+ WLAN sowie 1 Slave B2+, 2 Slave B+ und 2 Slave Raspi B. 5x Pi Cam; Imac mit OSX El Capitan; Iphone 6 plus; Ipad mini; Lenovo Android Tablet.
  • Interessant! Dann muss es wohl an dem fertigen Image liegen. Premo hier im Forum hat den SHC bereits erfolgreich auf dem RPi3 installiert. Er hatte wohl ein paar Schwierigkeiten mit der static IP, soweit ich mich erinnere. Musst Du mal hier im Forum suchen. Ist ja noch nicht lange her.

    Wenn Du nur den SHC auf dem RPi laufen lassen willst, oder nicht das ganze andere Gedönst brauchst, würde ich Dir zu Jessie light raten und mal von Grund auf installieren. Wenn das Image mal auf der Karte ist, geht das ja ganz fix.

    Nachtrag: Achso, hast Du denn die SD Karte mal in einem RPi2 probiert?
    SHC Master B2+ WLAN sowie 1 Slave B2+, 2 Slave B+ und 2 Slave Raspi B. 5x Pi Cam; Imac mit OSX El Capitan; Iphone 6 plus; Ipad mini; Lenovo Android Tablet.
  • Das Image so wie es jetzt ist wird denke ich nicht direkt auf dem Pi 3 gehen. Das wurde vor dem Release erstellt und wir somit auch nicht die nötigen Kernel Treiber an Board haben. Um das zum laufen zu bekommen müsste auf einem alten Pi 1 oder 2 erst einmal das Distributionsupdate gemacht werden.


    Shell-Script

    1. sudo apt-get update
    2. sudo apt-get upgrade
    3. sudo apt-get dist-upgrade
    Danach sollte das Image auch auf dem Pi 3 gehen.

    @Microgamer
    Könntest du das bei gelegenheit mit machen
  • Auf dem Pi 3 läuft das fertige SHC-Image nicht, da läuft nur das neuste Raspian vom 26.02.2016
    Ich hatte das auch schon mit dem fertigen SHC-Image probiert, der Pi 3 wollte es einfach nicht laden.
    Hatte alles neu gemacht und es läuft jetzt alles bestens.

    Du kannst dir natürlich von deinem Pi2 ein Image erstellen wenn er auf den neusten Stand ist, dauert aber genau so lange wie alles neu machen.
  • hm.... habs mit meinen Raspi 1 probiert: gab ne fehlermeldung :(


    Trigger für man-db (2.7.0.2-5) werden verarbeitet ...
    sTrigger für systemd (215-17+deb8u3) werden verarbeitet ...
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/raspberrypi-bootloader_1.20160225-1_armhf.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    pi@raspberrypi:~ $ sudo apt-get dist-upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Probieren Sie »apt-get -f install«, um dies zu korrigieren.
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    libraspberrypi0 : Hängt ab von: raspberrypi-bootloader (= 1.20160225-1) aber 1.20151118-1 ist installiert
    E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
    pi@raspberrypi:~ $ sudo apt-get dist-upgrade -f

    ...
    ...
    Fehler traten auf beim Bearbeiten von:
    /var/cache/apt/archives/raspberrypi-bootloader_1.20160225-1_armhf.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Versuche es doch wieder mit der Neuinstallation

    The post was edited 1 time, last by mounty77 ().

  • und warum machst Du nicht was dir der Raspi sagt?

    "Probieren Sie »apt-get -f install«, um dies zu korrigieren."

    Einfach das aktuelle Jessie lite verwenden und alles sauber zu fuss neu installieren. damit bin ich auch mein Sensorsenderanzeigefehler (puuuh langes Word) los geworden.
    Mein RPI3 rennt seit dem wie Butter.

    @premo, bei mir ist die neuinstallation sauber durchgelaufen:
    cu C-3po
  • Raspberry 3 - Download Image funkt nicht

    Man muss doch eh noch was ändern, wie Hostname, WLAN, update & upgrade.
    Da machen die paar Minuten für apache, PHP, rcswitch, pilight und SHC den Kohl auch nicht mehr fett.
    Dann macht man sich ein Image zur Sicherung und fertig.
    So oft braucht man das ja nicht.


    Gesendet von iPhone mit Tapatalk
    Gruß Dieter
    --------------
    Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.
  • Hallo,

    beim Versuch shc auf dem Raspi 3 (Jessi) zu installieren, bin ich als absoluter Linux-Anfänger gleich mal an der Kommandozeilen-Eingabe gescheitert, weil ich nicht weiß, was ich eingeben muss.

    Da ich shc nur mal kurz testen möchte, ob es für meine Anforderungen ausreicht, wäre natürlich ein fertiges Image für mich die einfachste Lösung.
    Kann sich hier jemand erbarmen, und mir ein Image zur Verfügung stellen? (Webspace wird gerne gestellt)

    Falls nein, lässt sich hier jemand noch weiter herab, und sagt einem Anfänger, wie er shc installieren kann?
    Ich habe mich versucht an diese Anleitung zu halten ( http://rpi-controlcenter.de/index.php?thread/740-shc-2-2-7-master-slave-auf-jessie-von-grund-auf-installieren/&postID=5668#post5668)

    aber ich scheitere schon daran, dass ich nach der Eingabe der Kommandos nicht weiß, was ich dann drücken muss.

    Wer hilft einem Anfänger, oder sagt mir, wo ich die Lösungen finde? Ich habe zwar versucht die Antworten im Netz zu finden, bin aber kläglich gescheitert.

    Dankeschön für die Hilfe im Voraus!

    Grüßle
    Käpsele